Build #284

Build and run tests under Java 11

Build: #284 was successful

Job: Clover and Tests was successful

Stages & jobs

  1. Default Stage

Job result summary

Completed
Duration
4 minutes
Agent
Default Agent
Revision
6377aab20b69421675cf56d539f5ba861f81fd7f 6377aab20b69421675cf56d539f5ba861f81fd7f
Total tests
1397

Tests

  • 1,397 tests in total
  • 1 test was fixed
  • 4 tests were skipped
  • 1 minute taken in total.
Fixed tests 1
Status Test Failing since Duration
Successful Jalview2xmlTests gatherViewsHere History
Failing since build #283 (Code changes detected) 3 secs

Error summary

The build generated some errors. See the full build log for more details.

Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
Note: Some input files use unchecked or unsafe operations.
Note: Recompile with -Xlint:unchecked for details.
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by jalview.gui.Desktop (file:/srv/bamboo/bamboo-home/xml-data/build-dir/196609/JB-GDB-JOB1/build/clover/clover-classes/) to field sun.awt.X11.XToolkit.awtAppClassName
WARNING: Please consider reporting this to the maintainers of jalview.gui.Desktop
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.codehaus.groovy.vmplugin.v7.Java7$1 (file:/srv/bamboo/home/bamboo/buildtools/gradle-5.6.4/lib/groovy-all-1.3-2.5.4.jar) to constructor java.lang.invoke.MethodHandles$Lookup(java.lang.Class,int)
WARNING: Please consider reporting this to the maintainers of org.codehaus.groovy.vmplugin.v7.Java7$1
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release